Fork me on GitHub
Not signed in (Sign In)
    • CommentAuthorowntheweb
    • CommentTimeMay 20th 2011 edited
     
    Referencing this example:
    http://flintparticles.org/examples/fountain-3d

    When I try to publish or preview a movie (any example), I'm getting a lot of compiler syntax errors for Emitter.as all similar to:

    Emitter.as, Line 146 1084: Syntax Error: expecting identifier before lessthan.

    Emitter.as, Line 146 looks like:
    protected var _initializers:Vector.<Initializer>;

    I'm using Flash CS3, with modifications to export for Flash Player 10 (works with my other libraries). It looks like my compiler doesn't like <Initializer>. Any thoughts on what I might be doing wrong? Am I using the wrong source? 3.0.1

    Best regards,

    Chris

    EDIT: Installing CS5 demo does the trick... for 30 days anyway. Is CS3 now too obsolete for FLiNT?
    • CommentAuthorRichard
    • CommentTimeMay 23rd 2011
     
    CS3 doesn't understand the Vector class, which was included in Flash 10, so is confused by the generic typing of the Vector class. I don't know of any way to get this working with CS3, sorry.

    If you must stick with CS3, you will be fine with version 2.2.1 of Flint, which you can get here.