Fork me on GitHub
Not signed in (Sign In)
  1.  
    I was working on this example http://flintparticles.org/examples/fountain-3d and ran into this problem http://twitpic.com/5lyyi8 today.

    Description Resource Path Location Type
    1046: Type was not found or was not a compile-time constant: Matrix3D. Quaternion.as /FLARdemo/src/org/flintparticles/threeD/geom line 629 Flex Problem
    Description Resource Path Location Type
    1046: Type was not found or was not a compile-time constant: Vector3D. Quaternion.as /FLARdemo/src/org/flintparticles/threeD/geom line 545 Flex Problem

    My target flash player is 10.2.0 because I'm using the flex sdk 4.5.1 with flash builder 4.5.1. Can someone please explain me what's wrong?
    • CommentAuthorRichard
    • CommentTimeJul 15th 2011
     
    Sorry, I don't know what's causing that problem. Can you post some code, that would make it easier to find the problem.
    • CommentAuthorgrapixsoft
    • CommentTimeJul 18th 2011
     
    The error is there straight after importing the Flint library to my project. I didn't event start the coding.
    • CommentAuthorRichard
    • CommentTimeJul 31st 2011
     
    Are you using Flash 9? Flint 3 requires Flash 10. Flint 2.2.1 is the latest Flash 9 compatible version. You can get that from the downloads.
  2.  
    Hi Richard.
    I too have a similar issue to this. I get the following error having just created a blank movie with the Document Class specified as ‘Main’:
    “…\src\away3d\core\render\Filter3DRender.as, Line 50 1046: Type was not found or was not a compile-time constant: Texture.”
    Error is repeated for line 101, same .as file.
    I’m publishing through Flash CS5 and am using the download from today (4_0_1) with the current Flash Player. Is the file download too new for CS5 and if so, which version should I use?
    By the way, myself and colleagues are blown away by what your particles can do. Absolutely brill.
    Michael :-)
    • CommentAuthorRichard
    • CommentTimeDec 14th 2011
     
    Hi michaelog193

    That sounds like an error in Away3d rather than in Flint - the class it's talking about is an Away3d class, not a Flint class. Are you using Away3d in your project?

    Richard
  3.  
    Yes Richard, I used the latest version of Away3d. Perhaps this needs an older version with CS5?
    Unfortunately I don't know enough about any of the three 3D systems to know which to use. Is there a resource which explains/compares them?
    I want to explore interactive spaces, using a camera to detect people (Difference Blend Mode?) then treat the shapes (people) as either magnetic or repulsive to particles which are projected vertically down from the ceiling. I'm a relative newbie, as you can tell, and would welcome advice from the Flint community.
    Cheers. Michael
    • CommentAuthorRichard
    • CommentTimeDec 15th 2011
     
    Hi Michael

    Flash CS5 doesn't know about Stage3D and all the other additions in Flash Player 11. I believe it's possible to configure it to work, but have never done it myself. This blog post by Richard Galvin should help - http://blogs.adobe.com/rgalvan/2011/11/adding-fp11-support-to-flash-pro-cs5-and-cs5-5.html.

    Richard